BANCO DE DADOS INESPLICAVELMENTE NAO ACESSA

 Tópico anterior Próximo tópico Novo tópico

BANCO DE DADOS INESPLICAVELMENTE NAO ACESSA

SQL / DATABASE

 Compartilhe  Compartilhe  Compartilhe
#489089 - 03/06/2019 16:20:45

WEBIER
URUCUI
Cadast. em:Dezembro/2003


Pessoal, uso VB6 e SQL 2008

uso a seguinte rotina para conectar (há anos)
   Dim cn1 As String, cn2 As String

   'Atribui falha na execução
   AbrirConexaoBD = False
  
   'pegar dados no arquivo txt
   Set oIni = New Ini
   oIni.Arquivo = appPathApp & "config.ini"
   var_IP = oIni.LerTexto("IP_MAQUINA", "ip")
   UTC = oIni.LerTexto("FUSOHORARIO", "UTC")
   Set oIni = Nothing
   'var_IP = "servidor\SQLEXPRESS2008"
   vgServerName = var_IP

   'Conexão padrão do SQL Server
   cn1 = "Provider=SQLOLEDB.1;Persist Security Info=False;DRIVER={Sql Server};SERVER=" + var_IP + ";uid=sa;pwd=190106web;DATABASE=cyber_base;TRUSTED_CONNECTION=NO"
   'cn1 = "Provider=SQLOLEDB.1;Persist Security Info=False;DRIVER={Sql Server};SERVER=" + var_IP + ";uid=lotesis;pwd=lotesis;DATABASE=cyber_base;TRUSTED_CONNECTION=NO"
  
   'Instancia os objetos
   Set dbData = New Database
  
   'Abre as conexões com os bancos de dados, em caso de erro sai da função
   If Not dbData.OpenConnection(cn1) Then Exit Function
  
   AbrirConexaoBD = AbreBancoDeDados    'Conexão estabelecida
   Exit Function                        'Sai da função


OBS: Nunca meixo nessa rotina
Pois Bem, semana passada... estou mexendo na parte de juros de parcelas no meu sistema... coloco para executar (testar)... do nada diz que o banco de dados nao tá acessivo:
-abro o SQL Server Management Studio, coloco a mesmo usuario "sa" e a mesma senha "190106web" e abre normal... abre tudo tabelas e registros
-olho o firewal... desativado como sempre
-desativo o anti virus
-no SQL Server Configuration Manager para a estancia e inicio novamente
-vejo a configuração do TCP/IP no SQL Server Configuration Manager =  Habilitado, IP4, 127.0.0.1, porta 1433.... tudo como antes
-Reinicio o Computador....
-troco o banco de dados pro outro... nada

Resumidamente, banco de dados operante... não foi feito nenhuma mudança no sistema... nem nas configurações... nada

Tive que formatar o notebook e instalar tudo novamente... agora imagina ai tanta coisa que tem q reconfigurar... de ocx até aplicativos

Ai deu certo...

Quando foi hj de manha, estava programando... executando e parando para fazer teste numa parte de impressão...

Adivinha? mesma coisa... banco de dados inacessivel

Fiz tudo que citei acima, menos formatar

Alguem tem alguma ideia?







#489092 - 03/06/2019 18:51:23

PLUGSOFTSM
SANTA MARIA
Cadast. em:Julho/2015


 Anexos estao visíveis somente para usuários registrados

Tenta seguir esses passos



Na opção Proprietário, escolha o logon que vc usa na string de conexão

Tenta conectar... provavelmente vai funcionar



 Tópico anterior Próximo tópico Novo tópico


Para responder este tópico o login é requerido
Se você já possui uma conta de usuário por favor faça seu login
Se você não possui uma conta de usuário use a opção Criar usuário