API COM ERRO AO EXECUTAR

 Tópico anterior Próximo tópico Novo tópico

API COM ERRO AO EXECUTAR

C#

 Compartilhe  Compartilhe  Compartilhe
#488092 - 03/04/2019 10:42:34

F001E
IBITINGA/SP
Cadast. em:Novembro/2004


 Anexos estao visíveis somente para usuários registrados

Bom dia a todos !

Peguei uma API para dar manutenção, porém o erro que corre eu nunca vi. Alguém já passou por isso ?





#488093 - 03/04/2019 10:49:42

KERPLUNK
RIO GRANDE DO SUL
Cadast. em:Junho/2009


Membro da equipe
Bem, me parece meio óbvio... o tipo de projeto é uma DLL(Library), o comando "dotnet run" serve para rodar algo e uma DLL não é algo rodável...

_______________________________________________________________________
Virei Oráculo!
The end is nigh, be ready for the nukes!


#488094 - 03/04/2019 10:53:24

GUIMORAES
ITAPETININGA
Cadast. em:Agosto/2009


Você chegou a verificar se no arquivo do projeto (seuprojeto.csproj), a tag TargetFramework está com netcoreapp2.0?

<TargetFramework>netcoreapp2.0</TargetFramework>

Além disso, você compilou sua aplicação? Rode 'dotnet build' antes de 'dotnet run'.





#488095 - 03/04/2019 10:57:57

F001E
IBITINGA/SP
Cadast. em:Novembro/2004


Última edição em 03/04/2019 10:58:17 por F001E

 Anexos estao visíveis somente para usuários registrados

Citação:
Bem, me parece meio óbvio... o tipo de projeto é uma DLL(Library), o comando "dotnet run" serve para rodar algo e uma DLL não é algo rodável...


Seria óbvio se no Output type estivesse setado Class Library.




#488096 - 03/04/2019 11:01:26

F001E
IBITINGA/SP
Cadast. em:Novembro/2004


Citação:
Além disso, você compilou sua aplicação? Rode 'dotnet build' antes de 'dotnet run'.


compilou normal



#488098 - 03/04/2019 13:29:18

GUIMORAES
ITAPETININGA
Cadast. em:Agosto/2009


Bom, aparentemente as suas configurações estão normais.

Você tem o SDK do .Net Core 2.1 e o Runtime instalados no seu ambiente?



#488102 - 03/04/2019 15:08:14

F001E
IBITINGA/SP
Cadast. em:Novembro/2004


Citação:
Bom, aparentemente as suas configurações estão normais.
Você tem o SDK do .Net Core 2.1 e o Runtime instalados no seu ambiente?


sim, tudo instalado.

Vou apagar o projeto e pegar do repositório novamente. Deve ter dado zica



#488103 - 03/04/2019 15:25:44

GUIMORAES
ITAPETININGA
Cadast. em:Agosto/2009


Você está tentando compilar ele no Visual Studio tradicional, certo? Já tentou executar ele no Visual Studio code?





#488110 - 03/04/2019 22:42:33

F001E
IBITINGA/SP
Cadast. em:Novembro/2004


Citação:
Já tentou executar ele no Visual Studio code?


A imagem é do VS Code. Rodei nos dois.



#488111 - 03/04/2019 23:37:02

KERPLUNK
RIO GRANDE DO SUL
Cadast. em:Junho/2009


Membro da equipe
Posta o texto do csproj.

_______________________________________________________________________
Virei Oráculo!
The end is nigh, be ready for the nukes!


#488116 - 04/04/2019 09:35:53

F001E
IBITINGA/SP
Cadast. em:Novembro/2004


 Anexos estao visíveis somente para usuários registrados

Acho que esse maluco fez alguma cagadinha, fiz merge e agora deu certo, mas olha a descrição do commit. kkkkkkkkkkkk



 Tópico anterior Próximo tópico Novo tópico


Tópico encerrado, respostas não sao permitidas
Encerrado por F001E em 04/04/2019 09:57:24